Why My Newly Added Event Log to OMS Not Appearing in Search


This blog post it is kind of short tip but also something you should pay attention to.

You might end up adding a event log to OMS but the events from that log not appearing in OMS.

Let’s say you want to add the Admin event log for Hyper-V-VMMS. In that case you will usually go to Event viewer and find the needed log.

image

You will copy the log name and add it to OMS and save changes:

image

After adding it of course you may have to wait 5 to 10 minutes until events starts showing up in OMS Search. Keep in mind that also new events have to be generated in order to be fetch by the OMS agent.

If new events are not shown after that time you will also see Event ID 26002 showing up in the Operations Manager log. That event will which particular log was not found on this machine:

image

We can clearly see that the event log with that name cannot be found.

So where is the problem than?

The problem is that not always the Log name is also the Full Name of the log. How to find the Full Name?

Just go to the properties of the event log itself and you will be able to find the full name:

image

After that you just need to add that name to OMS:

image

After that everything should be ok.

Remember always check for the full name when you add event logs.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s