Request Error on Calling Freshly Installed SCO 2012 R2 Preview Web Service


For some weeks I am having this issue with System Center Orchestrator 2012 R2 Preview. When I install the web service and the console and try to call the web service (http://localhost:81/orchestrator2012/orchestrator.svc/) I receive the following error:

image

Request Error

The server encountered an error processing the request. The exception message is ‘An error occurred while executing the command definition. See the inner exception for details.’. See server logs for more details. The exception stack trace is:
at System.Data.EntityClient.EntityCommandDefinition.ExecuteStoreCommands(EntityCommand entityCommand, CommandBehavior behavior) at System.Data.EntityClient.EntityCommandDefinition.Execute(EntityCommand entityCommand, CommandBehavior behavior) at System.Data.EntityClient.EntityCommand.ExecuteReader(CommandBehavior behavior) at System.Data.EntityClient.EntityCommand.ExecuteScalar[T_Result](Func`2 resultSelector) at System.Data.Objects.ObjectContext.ExecuteFunction(String functionName, ObjectParameter[] parameters) at Microsoft.SystemCenter.Orchestrator.WebService.OrchestratorContext.OnContextCreated() at invoke_constructor() at System.Data.Services.DataService`1.CreateProvider() at System.Data.Services.DataService`1.HandleRequest() at System.Data.Services.DataService`1.ProcessRequestForMessage(Stream messageBody) at SyncInvokeProcessRequestForMessage(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

I think the problem is how connected to that I am using remote clustered SQL instance but as I am not IIS expert it is hard to me to troubleshoot it. But I’ve found workaround.

The Workaround

Uninstall the SCO 2012 R2 web service and console and install SCO 2012 SP1 web service and console (all other SCO roles are 2012 R2). So far it seems this solution is working for me. I do not recommend using this solution but if you are in a stuck situation you can try it.

Advertisements

7 thoughts on “Request Error on Calling Freshly Installed SCO 2012 R2 Preview Web Service

  1. Hi, Did you ever find a solution to this problem? I am using the same setup as you with a clustered sql server.

    Thanks

      1. Hi Aengus,

        Orchestrator is setting DB permissions during install. Why the service account needs to be owner of the DB? And also which service Orchestrator service account – for management server or runbook servers?

  2. Hi Aengus,

    Thank you. After upgrading to Orchestrator R2 my Web Service and Console failed.
    After making the service account also DBO my Web Service and Console worked again.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s