SCVMM Maintenance mode for host does not put the computer object in maintenance mode in SCOM reported as fixed in SC 2012 SP1


Last week I’ve submitted a bug on a feature of SCVMM that I’ve spotted a long time ago. Due to various reasons I’ve somehow always forgot to submit it. The bug is that when you integrate SCOM 2012 and SCVMM 2012 you can put the Hyper-V host in maintenance mode in VMM and this will automatically put the Hyper-V host in maintenance mode in SCOM. This is true but to some extent. Actually only the objects in SCOM related to SCVMM are put in maintenance mode. What this means if you put the Hyper-V host in maintenance mode trough SCVMM and you restart that host you will still receive alerts like health service failure or failed to connect from SCOM about that host. The reason for that is if only objects related to VMM are put in maintenance mode other objects like the computer object, the health service and the agent watcher are still in active monitoring. A few days after submitting that bug in Microsoft Connect site I’ve received e-mail that this bug is closed as fixed:

image

As this issue is still present in System Center Virtual Machine Manager 2012 SP1 beta this leads me to believe that there are probably post beta releases for TAP customers which are not publically available. In a matter of fact there are some rumors over Internet that System Center 2012 SP1 has passed RTM and could be available early in January. I really hope so these rumors are true so we can have final release of Service Pack 1 for System Center 2012 as soon as possible. When RTM is available I will try to test if this bug is really fixed.

Advertisements

5 thoughts on “SCVMM Maintenance mode for host does not put the computer object in maintenance mode in SCOM reported as fixed in SC 2012 SP1

  1. Did you ever confirm if this was fixed in SP1 RTM as I was with a customer today with SP1 UR1 and it still only put the VMM related bits into Maint Mode, not the computer object.

    Regards,
    Steve

    1. Hi Steve,
      I’ve managed to test it in my home lab a couple of days ago and I can also confirm that is not fixed which is so unfortunate. To me this feature is not working as it should be. If you want to put Hyper-V host in maintenance mode in SCOM 99% of the cases you want to restart this node and you do not want to get alerts. I will try to write an article about this today or tomorrow and may be try to log this bug once again.
      Thank you for your feedback.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s