Update KB2585542 causes HP OpenView connector for SCOM not send alerts to OMU server


Once again I’ve stumbled on another interesting SCOM issue. First here is the environment:

SCOM01 – RMS server, HP OpenView connector service – Active

SCOM01 – MS server, OpsMgr DB, DW DB, Report server, HP OpenView connector service – Passive

OMU01 – HP Operations Manager for Unix server

SCOM01 is sending alerts to OMU01 via HP OpenView connector. After patching SCOM01 and SCOM02 the connector service stops sending alerts to OMU01. When the following command is ran on SCOM01:

winrm identify –r:OMU01:1270 –auth:basic –u:username –p:password –encoding:utf-8

HTTP error 501 is given. I’ve found similar issue with communication with Unix/Linux servers:

http://operatingquadrant.com/2012/01/12/opsmgr-unixlinux-heartbeat-failures-after-applying-kb2585542/

As SCOM is using winrm for communication with Unix\Linux and connectors the resolutions is the same:

  1. Uninstall the update KB2585542 
  2. Make a registry modification to disable the SecureChannel changes implemented in the update
  3. Modifying the registry to disable the SecureChannel changes:

    A “FixIt” package is available in the KB article under the Known Issues section that can be used to disable the security update
    Alternatively, you can add the 32bit DWORD value:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
    \SecurityProviders\SCHANNEL\
    SendExtraRecord = 2

After implementing those changes the connector started to work properly again.

Another case solved.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s